C++ ときどき ごはん、わりとてぃーぶれいく☆

Wonder Rabbit Projectのなかのひとのブログ。主にC++。

Arch Linux meets Dart Editor!

f:id:USAGI-WRP:20120304044915p:plain

Arch Linux meets Dart Editor!

LH-MAIN /tmp/test% yaourt -Ss dart-editor
aur/dart-editor 0.1.0.3934-3 (5)
    Editor for the Dart programming language.
LH-MAIN /tmp/test% uname -a
Linux LH-MAIN 3.2.8-1-ARCH #1 SMP PREEMPT Mon Feb 27 21:51:46 CET 2012 x86_64 AMD Phenom(tm) II X4 940 Processor AuthenticAMD GNU/Linux

Wow, I'm found the Dart-Editor package on AUR! Hmmm, I was lag behind. Let's install the package, now!

LH-MAIN /tmp/test% yaourt -S --noconfirm dart-editor

==> Downloading dart-editor PKGBUILD from AUR...
x PKGBUILD
x Changelog


Comment by: neokuno on Sun, 12 Feb 2012 11:45:55 +0000
There is no such thing as 'x86', it's i686, please correct it in PKGBUILD.

Comment by: nicoulaj on Sun, 12 Feb 2012 17:10:18 +0000
Thanks, fixed.

First Submitted: Mon, 07 Nov 2011 21:48:19 +0000
dart-editor 0.1.0.3934-3 
( Unsupported package: Potentially dangerous ! )
==> dart-editor dependencies:
 - java-runtime>=6 (already installed)
 - gtk2 (already installed)
 - desktop-file-utils (already installed)


==> Continue building dart-editor ? [Y/n]
==> -------------------------------------
==> 
==> Building and installing package
==> WARNING: Building package as root is dangerous.
 Please run yaourt as a non-privileged user.
==> Making package: dart-editor 0.1.0.3934-3 (Sun, 4 Mar 2012 04:23:09 +0000)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving Sources...
  -> Downloading DartBuild-linux.gtk.x86_64.zip...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
100 38.7M  100 38.7M    0     0   439k      0  0:01:30  0:01:30 --:--:--  497k
==> Validating source files with md5sums...
    DartBuild-linux.gtk.x86_64.zip ... Passed
==> Extracting Sources...
  -> Extracting DartBuild-linux.gtk.x86_64.zip with bsdtar
==> Starting build()...
  -> Generate desktop application entry...
==> Starting package()...
  -> Install the assembly at /opt/dart-editor...
  -> Install links to the executables in /usr/bin...
  -> Install links to the documentation resources in /usr/share/doc/dart-editor...
  -> Install link to the config file in /etc...
  -> Install desktop application entry in /usr/share/applications...
==> Tidying install...
  -> Purging unwanted files...
  -> Compressing man and info pages...
  -> Stripping unneeded symbols from binaries and libraries...
==> Creating package...
  -> Generating .PKGINFO file...
  -> Adding changelog file...
  -> Compressing package...
==> Finished making: dart-editor 0.1.0.3934-3 (Sun, 4 Mar 2012 04:25:20 +0000)

==> Continue installing dart-editor ? [Y/n]
==> [v]iew package contents [c]heck package with namcap
==> ---------------------------------------------------
==> 
loading packages...
resolving dependencies...
looking for inter-conflicts...

Targets (1): dart-editor-0.1.0.3934-3

Total Installed Size:   55.89 MiB

Proceed with installation? [Y/n] 
(1/1) checking package integrity                                                  [##############################################] 100%
(1/1) loading package files                                                       [##############################################] 100%
(1/1) checking for file conflicts                                                 [##############################################] 100%
(1/1) checking available disk space                                               [##############################################] 100%
(1/1) installing dart-editor                                                      [##############################################] 100%

ok. I'm complete installation of the Dart-editor from AUR powered by yaourt! It's very very easy as compared to the manual installation method. In corpore, I put the one line of the command only. Well, run it!

LH-MAIN /tmp/test% dart-editor

f:id:USAGI-WRP:20120304050550p:plain

Yeah, It's ok! ... maybe:)

と、なんだかC(ry先生が日本語を思い出されるまでの間に今日はEnglishでtalkingするのがa little waveだったらしいのでなんとなくEnglishで書いてみた・x・

まあ、ともかく Arch Linux では dart-editor とか公式手順をもさもさ読んでうにゅうにゅせんでもあっさり導入できる様になっています。さあ、Windows 8 Consumer PreviewでVisual Studio 11.0 Betaばかり遊んでいないでDartもしましょう☆ミ