C++ ときどき ごはん、わりとてぃーぶれいく☆

Wonder Rabbit Projectのなかのひとのブログ。主にC++。

GCC 4.6.2

C++11 <thread> GCC 4.6.2 は -pthread 付けないとダメよ

GCC4.6.2ではC++11のが凡そサポート済みという事になっている。ところが簡単なテストコードを書いてビルドしてみると std::system_error 例外がスローされる。whatには"Operation not permitted"。実はビルドする際に -std=c++0x の他に -pthread を付けない…